• このエントリーをはてなブックマークに追加
  • このエントリーをはてなブックマークに追加

GrowthPush SDK for iOS v.1.0.4を公開しました。

Downloads – GrowthPush

GrowthPush SDKは、iOS5.0以上をサポートしています。

v.1.0.3以前のSDKでは、iOS4.xで動作させるとアプリがクラッシュする問題がありましたが、v.1.0.4でこの問題を修正しました。

このバージョンでは、iOS 4.xでの動作をサポートしたわけではなく、iOS 4.xでクラッシュしないようにするため、GrowthPushの動作を停止させています。

iOS 4.xでも動作する必要がある場合は派生した下記のビルドを使用することができますが、今後のSDKのアップデートは予定されていません。

iOS4.3での動作のためAFNetworkingをダウングレードしたiOS SDKを作成

シェアが少ないことと現行のOSXとXcodeでiOS4.xのサポートがされていないことから、今後もiOS4.xへの対応は予定していませんが、iOS 5以上に対する機能の拡張は随時行っていきます。